• /
  • Log in
  • Free account

Rate limit errors (Prometheus integration)

Problem

Your Prometheus OpenMetrics integration for Docker or Kubernetes exceeded allowable metric rate limits. You want to see more details about why the NrIntegrationError event has been applied to your New Relic account.

Solution

To examine rate limit errors:

  1. Run a query of Prometheus metrics using the NrIntegrationError event, like this:

    FROM NrIntegrationError SELECT * WHERE newRelicFeature = 'Metrics'
  2. Review additional troubleshooting procedures for NrIntegrationError events.

To help prevent this from happening, you can use filters to control the types and amount of data that your integration sends to New Relic. For more information, see Ignore or include Prometheus metrics.

Cause

New Relic does a basic validation of your Prometheus OpenMetrics integration metrics when they are submitted. More extensive validation is performed asynchronously when processing the metrics.

If New Relic finds errors during this asynchronous validation, the errors are put into an NrIntegrationError event in your New Relic account. For example, if you exceed the metric limits defined for Prometheus OpenMetrics integrations, New Relic will apply rate limits to your account and create an associated NrIntegrationError event.

For more help

If you need more help, check out these support and learning resources:

Create issueEdit page
Copyright © 2021 New Relic Inc.