Problem
Your New Relic infrastructure agent is up and running, but when your CPU reaches a high percentage of usage, the agent stops intermittently to submit data.
Solution
Required agent version: 1.0.1002 or later
The following steps mitigate the data gaps problem:
Remove the limit of one thread for the agent, allowing one thread per core.
Use your init system to restart the agent service:
Cause
The New Relic Infrastructure agent, by default, runs in a single operating system thread. This may mean that, especially in Windows environments, the process scheduler gives it little chance to get CPU time when the system is overloaded.
The max_procs: -1
configuration option removes this limitation and allows the agent to use one thread per CPU core (as maximum).
For more help
If you need more help, check out these support and learning resources:
- Browse the Explorers Hub to get help from the community and join in discussions.
- Find answers on our sites and learn how to use our support portal.
- Run New Relic Diagnostics, our troubleshooting tool for Linux, Windows, and macOS.
- Review New Relic's and and documentation.