Problem
After you generate traffic and wait a few minutes, your .NET application does not report data to New Relic. In addition, there is no New Relic event log for your .NET app.
Solution
You may be running another profiler that conflicts with New Relic. Due to the architecture of .NET, you can run only one profiler at a time.
To verify whether New Relic is conflicting with another profiler:
Check your application event log for errors; for example:
NET Runtime version 2.0.50727.4234 - Failed to CoCreate profiler. Profiler CLSID: '{TRQGTQJM-KMJB-FQGP-VNGG-KUQTZWCKQ6QQ}'.NET Runtime version 4.0.30319.296 - Loading profiler failed during CoCreateInstance. Profiler CLSID: '{FF68FEB9-E58A-4B75-A2B8-90CE7D915A26}'.Compare the CLSID in the error to New Relic's CLSIDs:
71DA0A04-7777-4EC6-9643-7D28B46A8A41FF68FEB9-E58A-4B75-A2B8-90CE7D915A26Do one of the following:
- If the CLSID does not match, uninstall the other profiler.
- If the CLSID does match, check for CoCreateInstance permissions errors.
Cause
These NET Runtime version
errors indicate there is another .NET profiler running. The New Relic .NET agent must be registered as a profiler with the Common Language Runtime (CLR) as a profiler in order to function. The CLR calls out to the .NET agent when code is loaded, and the agent instruments the code for the method call as appropriate.
For more help
If you need more help, check out these support and learning resources:
- Browse the Explorers Hub to get help from the community and join in discussions.
- Find answers on our sites and learn how to use our support portal.
- Run New Relic Diagnostics, our troubleshooting tool for Linux, Windows, and macOS.
- Review New Relic's and and documentation.